Two Factor Authentication Delays
Incident Report for Aimtell
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 13:46 PDT
Investigating
We're currently investigating delays in two factor authentication codes being sent.
Posted Jul 25, 2022 - 13:37 PDT