3rd Party Issue: Billing Processor
Incident Report for Aimtell, Inc.
Resolved
This incident has been resolved.
Posted 16 days ago. Aug 31, 2019 - 22:44 UTC
Monitoring
Our billing processor, Recurly, has released a status report (https://status.recurly.com) about degraded performance. This may impact some areas of our platform - particularly features which may only be available on some paid plans or the ability to update billing plan information. We will continue to monitor potentially impact and circumvent wherever possible.
Posted 16 days ago. Aug 31, 2019 - 21:59 UTC
This incident affected: Dashboard.