Updates have begun rolling out to reduce delays of timezone optimized campaigns. We will be monitoring this throughout the day to ensure timezone optimized campaigns return to near real time delivery.
Posted Dec 07, 2022 - 11:25 PST
Investigating
We're investigating reports of timezone campaigns not sending as expected. We recommend any critical campaigns not use this feature until we've fully investigated the issue.