Delayed Click Reporting
Incident Report for Aimtell, Inc.
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 10, 2018 - 22:06 UTC
Identified
We've identified an issue impacting the speed at which clicks are being recorded. No tracking is lost, simply delayed.
Posted 2 months ago. Oct 10, 2018 - 19:51 UTC
This incident affected: Data Collection.