Delayed Click Tracking
Incident Report for Aimtell, Inc.
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 04, 2018 - 21:14 UTC
Identified
We've identified an issue causing delays in click tracking. No data is lost, clicks are just taking longer to record than usual.
Posted 2 months ago. Oct 04, 2018 - 16:46 UTC
This incident affected: Data Collection.